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[bookmark: _Ref73622127]Module 1: Using Names

What is Name?
In Excel, you can create names that refer to a single cell, a group of cells on the worksheet, a specific value, or a formula. After you define Excel names, you can use the names in a formula, instead of using a constant value or cell references.


An Excel name can't contain space characters, and there are other rules to follow when you're creating a name.

The first character of a name must be a
· letter
· underscore (_)
· backslash (\).

Subsequence characters in the name can be
· letters
· numbers
· periods
· underscore characters

Spaces are not allowed as part of a name.

Names can contain uppercase and lowercase letters. But Excel does not distinguish between them. For example, North and NORTH are treated as the same name.

Names cannot be the same as a cell reference, such as A2, A$35 or R2D2.

You cannot use C, c, R or r as a defined name -- they are used as selection shortcuts.



To create names:

[image: ]

Name Manager
Name Box



The advantages of using Names
There are few advantages when using names:
1. Can make the formulas easier to understand
2. Address independent. Make workbook maintenance easier
3. Single point of reference. Any future changes impact will be minimized.
4. The name will be utilized by other aspects of excel and will make those aspects better, for instance better scenarios summary and clearer solver constraints.



Name for single cell
[bookmark: _Ref73660996][image: ]EX1.1: Housing Loan

In this exercise you will learn how to use name to represent single cell.
1. Insert a new worksheet
2. Change the worksheet name to Housing Loan.
[image: ]
3. Prepare the worksheet as below:
[image: ]
4. Copy worksheet Housing Loan, and rename the copy as Housing Loan (Use Name).
[image: ]
5. Switch to worksheet Housing Loan (Use Name).
6. Select the Formulas Tab and then click Name Manager button.
[image: ]

7. You should able to see the following dialog box, click the New… button
[image: ]
8. Create the following names for the active worksheet.
	Name
	Scope
	Reference

	HousePrice
	Housing Loan (Use Name)
	D2

	LoanPercentage
	Housing Loan (Use Name)
	D3

	LoanAmount
	Housing Loan (Use Name)
	D4

	DownPayment
	Housing Loan (Use Name)
	D5

	AnnualRate
	Housing Loan (Use Name)
	D6

	DurationInYears
	Housing Loan (Use Name)
	D7

	MonthlyInstallment
	Housing Loan (Use Name)
	D8

	MinNetIncome
	Housing Loan (Use Name)
	D9

	TotalPayment
	Housing Loan (Use Name)
	D10

	FinancialCost
	Housing Loan (Use Name)
	D11



9. Change the cells value to the following:
[image: ]


Name for literal value and expression
[bookmark: _Ref73661140][image: ]EX1.2: Payroll

In this exercise you will learn how to use name to represent literal value and expression. 

Assuming you contribute 11% of your salary to EPF account, and your employer contributes 1% more.

1. Insert a new worksheet
2. Change the worksheet name to Payroll.
3. Declare a local name called BasicSalary refers to cell D2
4. The worksheet will be as below:
[image: ]
5. Declare the following names for the active worksheet:
	Name
	Scope
	Reference

	EPFEmployee
	Workbook
	=11%

	EPFEmployer
	Payroll
	=EPFEmployee+1%



6. Change the worksheet by using newly created names. Now the worksheet show be as below:
[image: ]



Name for multi-cells range
[bookmark: _Ref73661147][image: ]EX1.3: Employee
In this exercise you will learn more how to apply name to multi cells range.
1. Insert a new worksheet
2. Change the worksheet name to Empoyee.
3. Prepare the worksheet as below:
[image: ]
4. Create a new worksheet, and give it a name Lists.
5. In the Lists worksheet
a. Enter the data as shown
b. Select cell B3:B7
c. Click on the name box and type Departments followed by Enter.
[image: ]
You just created a workbook scope name called Departments represents range B3:B7. While in the Lists worksheet, click the name box drop down, you should be able to see the name from the drop down list.
[image: ]
6. Switch to Employee worksheet, click cell G3
[image: ]
7. Select tab Data and click Data Validation button.

[image: ]
8. In the dialog box, select Allow: List option
[image: ]
9. Key in the source as below:
[image: ]
10. Select the Input Message tab from the dialog box. Key in the input message a below:
[image: ]
11. Select Error Alert tab from the dialog box. Key in the Error message as below:
[image: ]
12. Press OK to end the dialog box.
13. Back to worksheet, click on dropdown button:
[image: ][image: ]


Name Scoping, ambiguity and conflict resolution
Name scope can be either
· Worksheet
· Workbook

The name under worksheet scope only can be referred within the worksheet without qualifier

The name under workbook scope can be referred within the entire workbook without qualifier

[image: ]Worksheet Qualifier


Ground rule: Name must be unique under the same scope.

For example, you can’t declare same names under same worksheet.
However, you can declare one name under workbook scope, and at the same time the same name under worksheet scope.

If ambiguity occurs, worksheet scope will shadow workbook scope. But this rule can be overwritten by using qualifier.


[bookmark: _Ref73661152][image: ]EX1.4: Naming conflict resolution
In this exercise you will learn how naming ambiguously is resolved.

1. Create a name X with workbook scope with value 100.
[image: ]

2. Create a local name X under worksheet Payroll with value 200.
[image: ]

3. Under cell A1 of worksheet Payroll, type “=X”
[image: ]

4. Press ESC to cancel the entry



Modify Name
The name and it reference can be changed only by using name manager. But the name scope can’t be modified. The only way to change the scope is delete it and create again with the new scope.

[bookmark: _Ref73661156][image: ]EX1.5: Modify Name
In this exercise, you will learn how to modify names
1. Run the Name Manager, select the workbook scope X, click Edit...
[image: ]
2. Change the value to 150, click OK.
[image: ]
3. Select name X under the Payroll Scope. Select Edit…
[image: ]

4. Change the name to Y.
[image: ]

5. Discuss how to change the scope of name X to scope of Housing Loan worksheet?






Delete Name
Name can be deleted by using Name Manager.

[bookmark: _Ref73661160][image: ]EX1.6: Delete Name
In this exercise, you will learn how to delete names
1. Run Name Manager. 

2. Select names X and Y. (Control Click for multiple select)
[image: ]

3. Press Delete.



[bookmark: _Ref73622153]Module 2: Using Table Features
Tables began as lists in the menu before version 2007, but they've become more powerful in the Ribbon versions. Converting a data range into a table extends functionality, which you can then use to work more efficiently and effectively. Here's a look at why you should consider using a table instead of an ordinary data range.

Bear in mind that as handy as tables are, they don't accommodate all of Excel's features. For example, you can't use Excel's Subtotal feature with tables. When you need a feature that tables don't support, temporarily convert the table into a range.

Some main benefits of using Table advantages over name ranges:
1. Easy sorting and filtering
2. Quick formatting
3. Effortless data entry
4. Automatic nomenclature
5. Quick totals
6. Always visible headers
7. Formula autofill
8. Dynamic charts
9. One-click select
10. Can allow access to various parts of the table

Creating a Table
Select the data range, then from the Home tab select:

[image: ]Common practice is try not to format the cell before apply table. The existing cell format will disturb the table color scheme.




[image: ]Delete Table
1. Right-click the table, point to Table, and then click Convert to Range.
2. On the Design tab, in the Tools group, click Convert to Range.

Caution that after convert to range, although the table is removed, but the format still remain. 

[bookmark: _Ref73661685][image: ]EX2.1: Create Table
In this exercise, you will learn how to create table
1. Switch to worksheet Lists.
2. Select range B2:B7
[image: ]
3. Select Home tab. Click Format as Table button. Select the table style you prefer.
4. Make sure that My table has headers in the dialog box is checked. Press OK.
[image: ]
5. Table is created.
[image: ]
6. To turn off the filter. Unselect the Filter option under Data tab.[image: ]


Change Table Name
When the table is created, it is given default name as Table#. Where # is number starts from 1 onward. But this default name is not meaningful to many applications. Therefore, normally is advisable to change it.
There are various ways to change name
1. Use Name Manager (Refer to next exercise)

2. Select any part of the table, on the Design tab, in the Properties group:
[image: ]

[bookmark: _Ref73661690][image: ]EX2.2: Rename Table
Continue from previous exercises, in this exercise, you will learn how to rename table
1. Run Name Manager. Select the newly created table, press Edit…
[image: ]

2. Change the name to TblDepartment.

3. Take note that only table name can be modified. Table cannot be deleted via Name Manager, and Tables always have workbook scope.

Sorting a Table
1. Right click any table column, select Sort and followed by the sort option
2. From Data ribbon tab, Sort & Filter group:
[image: ]
Filtering a Table
1. Right click any table column, select Filter and followed by the sort option
2. From Data tab, Sort & Filter group:
[image: ]
Working with the Total Row
You can use Total Row to apply aggregate function to individual column in the table.
1. Right click table, select Table and followed by Totals Row option

2. From Design tab, Table Style Options group:
[image: ]

3. Alternatively, you can use right-click option:
[image: ]




Creating a Calculated Column
New table columns can be created. These columns can derive value by referring to other columns in the same table. We call these columns as Calculated Column.

[image: ]
You will experience how to create this kind of columns later in other exercises.

Formatting a Table
Table can apply preset style to save efforts in formatting data. Before create table advisable to clear all formatting of the range. Otherwise, the existing format will disturb the selected style.

To change table style, go to Home tab, select style from Format as Table under Styles group. 

The other way is change the style from the Design tab, select style under Table Styles group.
[image: ]


Referring to different parts of table
Once table is created, data from table can be referred in the cell formula. 

We can refer to various part of the table:
	Part
	Example

	Table Data
	TblEmployee

	Table Header
	TblEmployee[#Headers]

	Table Totals Row
	TblEmployee[#Totals]

	Entire Table
	TblEmployee[#All]

	Entire Column
	TblEmployee[Gender]



[bookmark: _Ref73661698][image: ]EX2.3: Use Table Data in validation (Part-1)
The parts of table can be considered as range in many cases. Refer to worksheet Lists, we created both name Departments and table data TblDepartment. Both are referring to range B3:B7.

Previously we applied named range (Departments)validation of cell G3 under Employee worksheet. Since Departments and TblDepartment both refer to same range, can we substitute Departments with TblDepartment in the list data validation of cell G3 under Employee worksheet?

Let’s give it a try:
1. Switch to worksheet Employee.
2. Select Data tab, select Data Validation.
3. Change the Source under Settings tab to “=TblDeppartment”, press OK.
[image: ]
4. You will receive the following error message:
[image: ]
Although named range and table parts can be use interchangeable in many cases, however this case will fail. Table cannot be used directly under validation source.

5. Since table data cannot be use directly, we can use indirectly. Try change the source to
[image: ]
Beware that the TblDepartment must be enclosed in a pair of double quote marks.
INDIRECT is one of the complex functions from Excel.

6. Press OK. Test it by clicking the dropdown button
[image: ]
7. Now, delete the Departments name from Name Manager. Test the validation again.

8. Switch to Lists worksheet, select cell B7 (Sales),press Tab key, key in R&D.
[image: ]
9. Switch back to Employee worksheet, test the validation again.

The advantage of using table data for validation compare to named range is, if the list of data change in future, table data approach does not require to modify the reference from Name Manager as needed by the named range approach. 
[bookmark: _Ref73661702][image: ]EX2.4: Use Table Data in validation (Part-2)
The previous approach is adequate when the table only consists of one column. But tables in Excel can consist of multiple columns.

So, what is the impact to the previous approach? 
Assuming we need to add more data (columns) to the TblDepartment table.
1. Who is the department head?
2. How many employees in the each department?

 Let’s try the following steps:
1. Switch to Lists worksheet. Select cell C2 and type Head then press enter.
[image: ]
New column is inserted automatically (if cell C3:C8 are empty)

2. Add another column with header No. of Employees. Complete the data as below:
[image: ]

3. Now, switch Employee worksheet to the validation again.
[image: ]
Can you explain why you received the above validation list?

4. Now while selecting cell G3, select Data tab, click Data Validation.

5. Change the source to =INDIRECT("TblDepartment[Depatment Name]").

[image: ]

6. Press OK. Test the validation again.

7. Discuss why it is a good practice to include column header in the validation rule even for the single column table?




[bookmark: _Ref73622181]Module 3: Working with Formatting 

Applying Conditional Formatting
Conditional formatting allows you to automatically apply formatting—such as colors, icons, and data bars—to one or more cells based on the cell value. To do this, you'll need to create a conditional formatting rule.
[image: ]

Formatting based on Cells Values
Color code your data will provide special visual effect in analyzing data. You can let Excel show format of your choice when data fulfill certain criteria.
To do this, Select
Home Tab → Conditional Formatting→ New Rule…
Under New Formatting Rule dialog box, 
1) Select Format only cell that contain
2) Select equal to 
3) Key in the value
4) Press Format… button
[image: ]
Now you can decide the format that you want.
[image: ]
Press OK to complete the formatting. 
[image: ]
Ensure that the preview format is what you want, press OK to End. 

Formatting based on Formula
If the conditional options provided are not sufficient to handle some special situations, you can use formula to decide the formatting.
Under New Formatting Rule dialog box, 
1) Select Use a formula to determine which cells to format
2) Key in the formula (The formula must return True or False)
3) Press Format… button

[image: ]
Other Conditional Formatting (bars, scales, icons)
Condition Formatting in Excel also provides some others attractive formatting options such as
Data Bars
[image: ]
Color Scales
[image: ]
Icon Sets
[image: ] 
Using Data Validation
It is a good practice to prevent user enter unacceptable data by using Data Validation.
[image: ]

Entry guide
You can provide guide during user enter data.
[image: ]

Custom Error Message
Customize error message is important to let user know why they are wrong.
[image: ]



Creating and Using Custom Formats
Besides predefined format, custom formats can be defined for special cases.
1. Right-click on the cell(s)
2. Select Format Cells…
[image: ]

3. In the Format Cells dialog box, select Custom format
[image: ]



Using the Quick Analysis Tool
You can use the new Quick Analysis Tool in Excel to easy add conditional formatting, charts, totals, and tables to an Excel spreadsheet.
· New feature that lets you access data analysis tools easily
· Microsoft's research showed that many Excel users were simply not aware of the data analysis tools available in Excel
· Many users are reluctant to create charts or tables in Excel because they are worried about being to modify them later
· The Quick Analysis Tool puts data analysis features at your fingertips, as well as options for modifying these elements after you add them to your spreadsheet
[image: ]
Using Table for Validation
Common practice is to design validation rules for one row in the table. Every new row created later will automatically inherit the same validation.

Something to know about validation
Validation on take effect during user entry. But there are few scenarios validations will not take action. For example:
· Copy and paste
· Value assign by VBA code




[bookmark: _Ref73661707][image: ]EX3.1: Various types of validation
“Garbage in garbage out” means is data is incorrect, information will be invalid.

During data entry, it is very common data entered wrongly. To prevent invalid data, we can use data validation.

This exercise will provide different data validation alternatives

1. Switch to Employee.

2. Cell D3 is about Age. Add validation
[image: ]

Input guide: Valid age to be employee in Malaysia is in between 16 to 60 (inclusive)

Error Message: Invalid Employee Age!



3. Cell E3 is about Basic Salary. Add validation
[image: ]
Input guide: Minimum salary in Malaysia is $900
Error Message: Invalid Basic Salary!

4. Cell F3 is about Gender. Add validation
[image: ]
Input guide: Select gender from the list.
Error Message: Invalid Gender!


[bookmark: _Ref73661711][image: ]EX3.2: Adding calculated column
In this exercise you will learn how to add calculated column in the table.
1. Highlight cell B2:G3 of Employee worksheet.
[image: ]

2. Create a new table (with headers). Change the table name as TblEmployee.

3. Hide the filter buttons.
[image: ]

4. Select cell G3, press Tab to create a new row.
[image: ]

5. Complete the table data below:
[image: ]

6. [bookmark: OLE_LINK1]Select cell H2, type header Monthly Salary. Press Enter.
7. Select cell H3, and key the following (but don’t press enter yet)
[image: ]

8. While still in the entry, select cell E3. You should get the following:
[image: ]

9. Press Enter to confirm the formula.
[image: ]


10. Select range H3:H15, Select Home tab, select $ (currency format).


[bookmark: _Ref73661716][image: ]EX3.3: Using Data Bar
In this exercise you will learn how to use Data Bar Conditional Formatting.

1. Under Employee worksheet, select cell I2 then type header Chart. Press Enter. A new column is created.
[image: ]

2. While under cell I3, type = then select cell H3.
[image: ]

3. Press Enter.
[image: ]





4. Select range I3:I15, select Home tab, Conditional Formatting, Data Bars. And the bar style.
[image: ]


5. While still selecting range I3:I15, select Conditional Formatting, Manage Rules…
[image: ]




6. In the dialog box, select Data Bar format then click Edit Rule…
[image: Conditional Formatting Rules Manager]

7. In the next dialog box. Check the “Show Bar Only”:
[image: Edit Formatting Rule]

8. Press OK. Back to previous dialog box, press Apply then OK to end the dialog box.

9. Discuss your final result.
[bookmark: _Ref73661720][image: ]EX3.4: Detect Duplicate data
Imaging your tabular data consists of thousands of row, and some column must have unique value. How can you detect duplicate value entered?

In this exercise you will learn how to detect duplicate values during data entry by using conditional formatting.

1. Switch to Employee worksheet.

2. Select range B3:B15 of TblEmployee.
[image: ]
3. Select Home tab, Conditional Formatting, New Rules…
[image: ]
4. In the New Formatting Rule dialog box, select Format only unique or duplicate values option, click Format… button
[image: ]
5. In the Format Cells dialog box, select Font tab, Font style click Bold, Color select Yellow.
[image: ]
6. While still in the Format Cells dialog box, select Fill  tab, select Background Color as Red. Click OK.
[image: ]

7. Click OK again to end the Format Cells dialog box.

8. Try to add new row by intentionally key in existing EID.
[image: ]




9. Discuss your observation.
[image: ]

10. Delete the newly created row by right click the new row, then select Delete, Table Rows.
[image: ]



[bookmark: _Ref73622189]Module 4: Information Retrieval	
[bookmark: _Hlk73620503]To retrieve valuable information from Excel data you can use
1. Observation Techniques
2. Basic features such as Filter & Sorting
3. Functions and Formulas
4. Advanced Features such as Pivot Tables and Power-4
5. Programming such as VBA 
In this intermediate training, we will not cover Power-4 and Programming. 
Observation Techniques
By leveraging on the Conditional formatting (in Module-3) and Charting (in Module-5), we can visualize the information without extra effort.
Basic Features – Filter and Sorting
Excel provides some basic features to allow users focusing on certain aspects of information and allow reorder the data in the sequence to ease information retrieval.  
Filtering is the basic feature to hide unnecessary data so that users can derive valuable information. 
Sorting is the basic feature to rearrange data sequence to help users to derive information from it.
Using Functions and Formulas
The above-mentioned basic features require users to manually retrieve information. If, the information acquired is needed to be an input to another part of the model, this manual process will allow room to make mistake.
To solve this problem, Excel provides functions and formula to retrieve information and link them to other part of model.
The complete set of functions you can refer to Microsoft official site:
https://support.microsoft.com/en-us/office/formulas-and-functions-294d9486-b332-48ed-b489-abe7d0f9eda9?ui=en-US&rs=en-US&ad=US#id0eaabaaa=functions
Using Pivot Table
PivotTable is one of the unique powerful features provided by Excel. It is one of the main reasons so many users decided to use Excel instead of other tools in data analysis. 

With Pivot Table, user can find useful information from different perspectives of data. It allows users to extract the significance from a large, detailed data set.
[bookmark: _Ref73661797][image: ]EX4.1: VLookup (Exact Match)
In this exercise you will learn how to use VLookup exact match to retrieve data from another table.

Consider the case where company need to know the KPI of each employee. A new table will be created.

1. Create a new worksheet with name KPI.

2. Prepare the following table
[image: ]

3. Discuss what are the issues if the user needs to key in employee name?

4. Prepare a column formula for cell C3
[image: ]

5. Add data validation to cell B3
[image: ]

6. Try to select different EID
[image: ]

7. Discuss your observation

8. Try to delete cell B3’s value. Discuss your observation

9. Convert the tabular data to table and name it as TblKPI.
[image: ]
10. Try to add few new records, identify any problem occurs and suggest solution.

11. How to highlight duplicate EID selection?



[bookmark: _Ref73661802][image: ]EX4.2: VLookup (Approximate Match)
From the previous created table TblKPI, the management needs to make decision about the average performance of each employee based on the table below:
	Average Performance
	Action

	Below 40%
	Warning Letter

	40% to less than 70%
	(No Action)

	70% to less than 80%
	Increase Salary

	80% to less than 90%
	Promotion

	90% onward
	Increase Salary + Promotion



A new column with header Action will be added to TblKPI. The value of this column will be derived from column Average and the abovementioned table. 
1. Create a new table with name TblAction under worksheet Lists.
[image: ]

2. Switch to worksheet KPI. Prepare the data in the TblKPI table.
[image: ]

3. Add new column Action to table TblKPI under worksheet KPI.
[image: ]

4. Add column formula to column Action of table TblKPI.
[image: ]This part of formula will be added by just click on cell H3


5. Discuss your observation.

6. Select cell I6, press TAB key to generate new row.
[image: ]
 
Beware that we still have these few problems.

Fix Your VLookup Error
Sometime we want to silent about unsuccessful lookup or error generated from calling the VLookup function. In Excel 2007 you can use the following approaches:
1. Check the data before calling VLookup

2. Let the VLookup generate error and substitute the error with something else.





[bookmark: _Ref73661807][image: ]EX4.3: Create PivotTable
In this exercise, you will learn how to create PivotTable to analysis data from Employee table.
1. Select TblEmployee from Excel Name Box.
[image: ]
2. This will bring you to the TblEmployee table. While the table is selected, select Insert tab. Select PivotTable button.
[image: ]
3. In the Create PivotTable dialog box, just press OK button.
[image: ]
4. A new PivotTable is created in new worksheet.
[image: ]
[bookmark: _Ref73661814][image: ] EX4.4: View fields and data
In this exercise, you will learn how to view field and data from a PivotTable.
1. From the previously created PivotTable
a. Drag the Department field to Report Filter.
b. Drag the Gender field to Row Labels.
c. Drag the Gender field again to Value.
[image: ]
What kind of information the PivotTable showing now?

2. Try to select Filter button under Report Filter. Just select IT then press OK.
[image: ]
What kind of information the PivotTable showing now?


3. Now Drag the Department field from Report Filter to Column Labels. Observe the result produced.
[image: ]

4. Try to play around with the PivotTable to find out the following information:
a. Number of employees for each department
b. Average employee Monthly Salary for each department
c. Average Salary for different gender

Give your PivotTable a name
When PivotTable is created, Excel will assign a default name to it. If you want to rename it, there are many possible ways. One of the simplest ways is
1. Select Options tab

2. Change the name from the PivotTable Name field

[image: ]



Change field settings
When fields are dragged to the areas, Excel will provide default setting for the fields. Sometime the customization of the field is needed. 

To change the field setting, just click on the dropdown arrow for each field:
[image: ]

You should be able to find the Field Settings…
[image: ]

Styles
To change the PivotTable style,
1. Select Design tab
[image: ]

2. You can select any desire style

3. More style will be listed if you select the dropdown button.



[bookmark: _Ref73661818][image: ] EX4.5: Filter a field
In this exercise, you will learn how to filter a field to hide unwanted candidates.
1. From the previous PivotTable, select Column Labels dropdown button.
[image: ]

2. Just select IT, Operation, and R&D. Press OK.
[image: ]

3. Observe the result.



[bookmark: _Ref73661822][image: ] EX4.6: Create PivotChart
A pivot chart is the visual representation of a pivot table in Excel. Pivot charts and pivot tables are connected with each other. In this exercise, you will learn how to create PivotChart.
1. Select TblEmployee from Excel Name Box.
[image: ]
2. This will bring you to the TblEmployee table. While the table is selected, select Insert tab. Select PivotTable dropdown button, then select PivotChart.
[image: ]
3. In the Create PivotTable with PivotChart dialog box, just press OK.
[image: ]
4. Try to drag around with the PivotTable to find out the following information:
a. Drag the Department field to Row Labels.
b. Drag the Gender field to Report Filter.
c. Drag the Gender field again to Value.

5. Try to change other setting to make the final result looks like the following:

[image: ]
 

[bookmark: _Ref73622202]Module 5: Working with Charts	
Creating Charts
When presenting information, picture normally is better than thousands words. Charting allows use visualize our data/information graphically.
[image: ]

[bookmark: _Ref73661828][image: ]5.1: Add Chart
In this exercise, you will learn how to add column chart in to worksheet.
1. Switch to Employee worksheet. Select columns Name and Age from table TblEmployee.
[image: ]

2. Select Insert tab. Column button. Under 2-D Column, select first chart (Clustered Column) type.
[image: ]
3. New clustered column chart is created as below:
[image: ]
4. While the chart is selected, select the More dropdown button under Design tab.
[image: ]
5. Select the any design.
Changing the Chart Location and Size
You can easily move and resize chart simply by using mouse.
Chart also can be moved to other sheet.

[bookmark: _Ref73661835][image: ]5.2: Move Chart
In this exercise, you will learn how to move chart to new chart sheet.
1. Right click the previously created chart, select Move Chart…
[image: ]
2. In the Move Chart dialog box,type Employee-Age under New sheet field. Click OK.
[image: Move Chart]

3. A new chart sheet is created





Changing the Chart Type
To change chart type, just right click on the chart then select Change Chart Type…
[image: ]

Modifying Chart Elements
You can select the chart elements and format them separately. Example:

[image: ]

Formatting Chart Elements
The appearance of the chart element can be change independently by select and right click, then change from the floating menu.
[image: ]

Adding and Removing Data Series
Charts may have multiple data series.
 
[image: ]



[bookmark: _Ref73661841][image: ]EX5.3: Create multiple Data Series chart
In this exercise, you will learn how to create multiple data series chart.
1. Switch to Employee worksheet. Select Columns (Inclusive headers) Name, Basic Salary and Monthly Salary.
Hint: use control-select to select disjointed range.
[image: ]
2. Select Insert tab, Recommended Charts button under Charts group, click Clustered Column chart type.
[image: ]

3. New multiple data series chart is created.



[bookmark: _Ref73661844][image: ]EX5.4: Remove Data Series
In this exercise, you will learn how to remove data series from chart.
1. Right click on the previously created multiple data series column chart. Click Select Data… option.
[image: ]
2. In Select Data Source dialog box, select Monthly Salary under Legend Entries (Series) then click Remove button. Click OK to end the dialog box
[image: ]




3. Now the chart change to
[image: ]

Applying a Chart Filter
Chart Filter allow users to exclude subset of data from the chart.
[image: ]


Printing Charts
To print chart, common practice is
1. First of all, move the chart to separate chart sheet. 
2. Make sure that the chart sheet is active sheet
3. Click File menu, select Print menu item, the Print option
4. In the Print dialog box, select the printer in used and configure printer properties. Ensure that Active sheet(s) is selected then click OK to start printing.
[image: ]

Creating and Using a Chart Template
After you created a chart with the format or style that you like, you can then save it as chart template. Just right-click the chart, select “Save as Template”.

[image: ]
In the future you can apply the chart template to other chart with the same type. With this you are not only save time, consistency of look and feel for the charts with the same type are preserved.

[bookmark: _Ref73661848][image: ]EX5.5: Sparkline
Sparklines in Excel are graphs that fit in one cell. Sparklines are great for displaying trends. 

In this exercise, you will learn how to use Sparklines.
1. Refer to the previously created TblKPI:
[image: ]
2. Add a new column “Trend” after Action column:
[image: ]
3. Select the first cell just under the Trend title[image: ]:
4. Go to Insert ribbon tab. Select line sparkline:
[image: ]
5. In Create Sparklines dialog box, select value Q1 to Q4 on the same row, the press OK:
[image: ]
6. A Sparkline is created in the selected cell:
[image: ]
7. While the newly created sparkline still selected, check the Markers from the Design ribbon tab:
[image: ]
8. Drag the auto-fill handle until the end of table:
[image: ]
9. What is your conclusion to Mr Yong’s performance?
[image: ]


[bookmark: _Ref73622212]

[bookmark: _Ref73659896]Module 6: Protection	
Protecting Workbooks and Worksheets
To prevent other users from viewing hidden worksheets, adding, moving, deleting, or hiding worksheets, and renaming worksheets, you can protect the structure of your Excel workbook with a password.
Notes: Protecting the workbook is not the same as protecting an Excel file or a worksheet with a password.
[bookmark: _Ref73661931][image: ]EX6.1: Protect the workbook structure
To protect the structure of your workbook, follow these steps:
1. Click Review > Protect Workbook. 
[image: ]
Note: The Windows option is available only in Excel 2007, Excel 2010, Excel for Mac 2011, and Excel 2016 for Mac. Select the Windows option if you want to prevent users from moving, resizing, or closing the workbook window, or hide/unhide windows.
2. Enter a password in the Password box.
[image: Protect Structure and Windows]
Important: The password is optional. If you do not supply a password, any user can unprotect and change the workbook. If you do enter a password, make sure that you choose a password that is easy to remember. Write your passwords down and store them someplace safe. If you lose them, Excel cannot recover them for you.
3. Select OK, re-enter the password to confirm it, and then select OK again.


[bookmark: _Ref73661937][image: ]EX6.2: Protecting a Workbook
To prevent others from accessing data in your Excel files, protect your Excel file with a password.
1. Select File > Info.
[image: ]
2. Select the Protect Workbook box and choose Encrypt with Password.
[image: ]
3. Enter a password in the Password box, and then select OK.
4. Confirm the password in the Reenter Password box, and then select OK.
Warning: 
· Microsoft cannot retrieve forgotten passwords, so be sure that your password is especially memorable.
· There are no restrictions on the passwords you use with regards to length, characters or numbers, but passwords are case-sensitive.
· It’s not always secure to distribute password-protected files that contain sensitive information such as credit card numbers.
· Be cautious when sharing files or passwords with other users. You still run the risk of passwords them falling into the hands of unintended users. Remember that locking a file with a password does not necessarily protect your file from malicious intent.
[bookmark: _Hlk73660575][bookmark: _Ref73661941][image: ]EX6.3: Protecting a Worksheet
To prevent other users from accidentally or deliberately changing, moving, or deleting data in a worksheet, you can lock the cells on your Excel worksheet and then protect the sheet with a password. Say you own the team status report worksheet, where you want team members to add data in specific cells only and not be able to modify anything else. With worksheet protection, you can make only certain parts of the sheet editable and users will not be able to modify data in any other region in the sheet.
Choose what cell elements to lock
Here's what you can lock in an unprotected sheet:
· Formulas: If you don’t want other users to see your formulas, you can hide them from being seen in cells or the Formula bar
· Ranges: You can enable users to work in specific ranges within a protected sheet

[bookmark: _Ref73661947][image: ]EX6.4: Allowing Users to Edit Ranges
Worksheet protection is a two-step process: the first step is to unlock cells that others can edit, and then you can protect the worksheet with or without a password.
Step 1: Unlock any cells that needs to be editable
1. [bookmark: _Ref73622221]In your Excel file, select the worksheet tab that you want to protect.
2. Select the cells that others can edit.
Tip: You can select multiple, non-contiguous cells by pressing Ctrl+Left-Click.
3. Right-click anywhere in the sheet and select Format Cells (or use Ctrl+1, or Command+1 on the Mac), and then go to the Protection tab and clear Locked.
[image: Protection tab in the Format Cells dialog box]
Step 2: Protect the worksheet
Next, select the actions that users should be allowed to take on the sheet, such as insert or delete columns or rows, edit objects, sort, or use AutoFilter, to name a few. Additionally, you can also specify a password to lock your worksheet. A password prevents other people from removing the worksheet protection—it needs to be entered to unprotect the sheet.
Given below are the steps to protect your sheet.
1. On the Review tab, click Protect Sheet.
[image: The Changes group on the Review tab]
2. In the Allow all users of this worksheet to list, select the elements you want people to be able to change.
[image: ]
3. Optionally, enter a password in the Password to unprotect sheet box and click OK. Reenter the password in the Confirm Password dialog box and click OK.
Important: 
· Use strong passwords that combine uppercase and lowercase letters, numbers, and symbols. Weak passwords don't mix these elements. Passwords should be 8 or more characters in length. A passphrase that uses 14 or more characters is better.
· It is critical that you remember your password. If you forget your password, Microsoft cannot retrieve it.
[bookmark: _Ref73659921]

[bookmark: _Ref73662222]Module 7: Using Styles and Templates	
Working with Cell Styles
To apply several formats in one step, and to make sure that cells have consistent formatting, you can use a cell style. A cell style is a defined set of formatting characteristics, such as fonts and font sizes, number formats, cell borders, and cell shading. To prevent anyone from making changes to specific cells, you can also use a cell style that locks cells.
[bookmark: _Ref73661953][image: ]EX7.1: Apply a cell style
1. Select the cells that you want to format.
2. On the Home tab, in the Styles group, click the More dropdown arrow in the style gallery, and select the cell style that you want to apply.
[image: More dropdown arrow in the Styles gallery]


[bookmark: _Ref73661957][image: ]EX7.2: Create a custom cell style
1. On the Home tab, in the Styles group, click the More dropdown arrow in the style gallery, and at the bottom of the gallery, click New Cell Style.
[image: ]
2. In the Style name box, type an appropriate name for the new cell style.
3. Click Format.
4. On the various tabs in the Format Cells dialog box, select the formatting that you want, and then click OK.
5. Back in the Style dialog box, under Style Includes (By Example), clear the check boxes for any formatting that you do not want to include in the cell style.
6. Click OK.


[bookmark: _Ref73661962][image: ]EX7.3: Create a cell style by modifying an existing cell style
1. On the Home tab, in the Styles group, click the More dropdown arrow in the style gallery.
[image: More dropdown arrow in the Styles gallery]
2. Do one of the following:
· To modify an existing cell style, right-click that cell style, and then click Modify.
· To create a duplicate of an existing cell style, right-click that cell style, and then click Duplicate.
3. In the Style name box, type an appropriate name for the new cell style.
Note: A duplicate cell style and a renamed cell style are added to the list of custom cell styles. If you do not rename a built-in cell style, the built-in cell style will be updated with any changes that you make.
4. To modify the cell style, click Format.
5. On the various tabs in the Format Cells dialog box, select the formatting that you want, and then click OK.
6. In the Style dialog box, under Style Includes, select or clear the check boxes for any formatting that you do or do not want to include in the cell style.


[bookmark: _Ref73661966][image: ]EX7.4: Remove a cell style from data
You can remove a cell style from data in selected cells without deleting the cell style.
1. Select the cells that are formatted with the cell style that you want to remove.
2. On the Home tab, in the Styles group, click the More dropdown arrow in the style gallery.
[image: More dropdown arrow in the Styles gallery]
3. Under Good, Bad, and Neutral, click Normal.
[bookmark: _Ref73661971][image: ]EX7.5: Merging Style
You can merge style from other open workbooks.
1. On the Home tab, in the Styles group, click the More dropdown arrow in the style gallery, and at the bottom of the gallery, click Merge Style.
[image: ]
2. In the Merge Styles dialog box, choose open workbooks to merge style from. 


[bookmark: _Ref73661975][image: ]EX7.6: Delete a predefined or custom cell style
You can delete a predefined or custom cell style to remove it from the list of available cell styles. When you delete a cell style, it is also removed from all cells that are formatted with it.
1. On the Home tab, in the Styles group, click the More dropdown arrow in the style gallery.
[image: More dropdown arrow in the Styles gallery]
2. To delete a predefined or custom cell style and remove it from all cells that are formatted with it, right-click the cell style, and then click Delete.



Using Templates
If you often use the same layout or data in a workbook, save it as a template so you can use the template to create more workbooks instead of starting from scratch.
You can use one of your own templates to create a new workbook, or you can use one of the many predefined templates that you can download from Microsoft Office Online.
[bookmark: _Ref73661980][image: ]EX7.7: Save a workbook as a template
1. If you’re saving a workbook to a template for the first time, start by setting the default personal templates location:
a. Click File > Options.
b. Click Save, and then under Save workbooks, enter the path to the personal templates location in the Default personal templates location box.
This path is typically: C:\Users\[UserName]\Documents\Custom Office Templates
[image: Options you can set for saving workbooks]
c. Click OK.
2. Open the workbook you want to use as a template.
3. Click File > Export.
4. Under Export, click Change File Type.
5. In the Workbook File Types box, double-click Template.
6. In the File name box, type the name you want to use for the template.
7. Click Save, and then close the template.

[bookmark: _Ref73661986][image: ]EX7.8: Create a workbook based on the template
With the template you created above, you can create a new workbook. This section tells you how to do that.
Note: Alternately, you can browse for various online templates in Excel and use them instead.
1. Click File > New.
2. Click Personal.
[image: Personal templates location]
3. Double-click the template you just created.
Excel creates a new workbook that is based on your template.
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